Duvida Iniciante sobre App

Link para discução: http://lliure.com.br/hub/apm=comunidade/sapm=comunidade/sapm=forum/cmd=21333/topico=68
Diego - 04/02/2013

Boa noite, sou novo aqui no forum e novo com essa parada de desenvolvimento para android, ja mexi com vb e sites, mais android primeira vez, então assim estou com uma tremenda duvida... meu primeiro app eu fiz somente um botão que ao clicar redirecionava para o navegador do Celular, eu consegui de boa sem problemas, instalei no meu Android funcionou de boa, agora eu estou fazendo o mesmo só que ao inves de redirecionar para o navegador do celular, to fazendo para aparecer diretamente na tela do app, ja fiz os codigos e tudo certinho criei a \"WebView\" e tudo corretamente, porem no emulador do android o app abre mais fica com o fundo branco e não aparece a pagina que eu programei \"http://www.ask.fm\" isso ja ta me quebrando a cabeça porque os codigos .xml e .java não tem nenhum erro, se alguem souber me ajudar eu agradeço muito, e desculpa se eu postei na area errada ou seila, como eu disse sou novo no forum e não achei nada parecido.

Cassiano - 04/02/2013

Tente ver se você está concedendo todas as permissões necessárias para seu aplicativo no AndroidManifest. Ou se ele rodar no seu celular mas não rodar no emulador, o problema esta no emulador :)

Diego - 04/02/2013

Obrigado por responder Cassiano, então eu coloquei aquela permissão para ele poder acessar a internet mas mesmo assim a pagina não abre no app fica tudo branco, no emulador não rodou no meu celular também não foi, eu até nem sei o que fazer, pois algo errado tenho certeza que não está e como eu sou novo no assunto não sei muito o que fazer

Cassiano - 04/02/2013

E no logcat, quando você executa não aponta nenhum erro?

Diego - 05/02/2013

No logcat ele aponta alguns erros em vermelho mais eu não sei ver aquilo direito, por só ter bem o basico de eclipse

Cassiano - 05/02/2013

 

<p class=\"western\">Hum... bem então aconselho você a procurar alguns exemplos na internet, talvez assim você descubra aonde está o problema no seu app. :)

<p class=\"western\">
Tava dando uma olhada aqui e acho que esses tutos podem lhe ajudar:

 

<p class=\"western\">http://devmobilebrasil.com.br/android/webview-android/ - Este é um exercício prático que ensina a utilizar uma WebView, em PT.

 

<p class=\"western\">http://developer.android.com/guide/webapps/webview.html - Este é uma explicação da WebView só que de uma maneira mais \"avançada\" e talvez mais complicada para você que é iniciante... mas se você tiver uma noção de inglês acredito que vá lhe ajudar.

 

Quase todos direitos reservados a Newsmade
Newsmade